Sistema

tsaSchool™. Sistema

Asistente de la escuela del ministerio teocrático

El sistema tsaSchool, es un verdadero asistente para el superintendentes de la Escuela del Ministerio Teocrático. Está lleno de funcionalidades suyo propósito es simplificar el trabajo del encargado de la escuela a fin de que pueda concentrarse en lo más importante: velar por el progreso de cada uno de los matriculados en la escuela.

Esperamos ir agregando toda la ayuda, actualizaciones, versiones, sugerencias y demás información poco a poco en esta misma página. !Así que no deje de visitarla!.

Dese un tiempo para explorarlo y ver todas las opciones que posee. Verá que es uno de los mejores asistentes para la escuela que se puede encontrar.

Copyright (c) 2010 tsaSoftware® http://tsasoftware.zxq.net/


Funcionamiento

tsaSchool™. Funcionamiento

Cómo Funciona!

Sólo hay que instalar el .Net Framework 2.0 de Microsoft (que ya viene con XP SP3 y con Vista o Win7) y luego uno descomprime el .ZIP en la carpeta donde quiere que esté el sistema.

Para usarlo, el sistema cuenta con una barra de opciones para las funciones principales de trabajo. Al darle clic, se despliegan una a una las opciones de trabajo.

Generación: muestra las opciones para generar un programa completo de la escuela, desde modificar (si es necesario) los datos del programa de la escuela, hasta crear las asignaciones, imprimirlas y llevar un control de las asignaciones que han sido entregadas.

Calificación: muestra las opciones de trabajo más frecuentemente utilizadas por el superintendente de la escuela: crear una hoja con los datos de las parte de cada sala de una semana para calificarlas, ingresar los datos de calificación de cada parte (si cumplió con el aspecto de oratoria, el tiempo, si necesita trabajar en otro aspecto, detalles importantes, etc).

Reportes: brinda una serie de opciones para imprimir reportes, como los resultados de la escuela de un mes completo, la tabla de asignaciones, etc.

Utilitarios: muestra una serie de opciones de gran utilidad para el sistema: la ventana de configuración (que permite configurar una serie de datos del sistema: título del programa, ajustes de impresión, cómo mostrar los datos, si se quieren ver los mensajes de ayuda y referencias de los estudiantes, día de la semana en que se lleva a cabo la escuela, cantidad de salas, cuántos elementos ver en la lista de matriculados sugeridos, etc .) , funcionalidad de backup de los datos, y notas de ayuda para el superintendente de la escuela teocrática.

Cerrar: como indica su nombre, esta no es una lista de opciones, es el botón de cerrar. Por defecto, el sistema le preguntará si realmente desea cerrarse.

Es muy intuitivo y completo, y es una maravilla para dar seguimiento a cada hermano matriculado.


Botones generales

tsaSchool™. Botones generales

Botones de Pantalla

En casi todas las ventanas se encuentran los mismo íconos en los botones de funciones. Esto se ha hecho así pensando en facilitar el manejo pues todas ventanas presentan opciones estándar.

Esta es la lista de los botones generales y para lo que sirven:

Guardar: Permite guardar los datos de la ventana activa

Agregar: permite agregar un elemento a la lista actual. Normalmente se utiliza para agregar el elemento seleccionado de una lista inicial a una lista de trabajo.

Eliminar: permite quitar el elemento seleccionado de la lista actual.

Modificar: permite modificar el elemento seleccionado.

Cancelar: Permite cancelar cualquier modificación que se haya realizado en la ventana activa

Imprimir: Permite imprimir directamente a la impresora un dato de la ventana activa. Sólo la ventana de impresión de asignaciones imprime directamente a la impresora. Todas las demás muestran una ventana con los datos a imprimir antes.

Visualizar e Imprimir reporte. Muestra una ventana con el reporte generado para ser impreso, guardado o exportardo.

Consultar: realizar la consulta de los datos de la ventana.

Excel. Permite exportar el reporte actual a Microsoft Excel.

Word. Permite exportar el reporte actual a Microsoft Word.

Navegador: Permite abrir el reporte actual en el navegador de internet por defecto en la PC.

Procesos. Realizan procesos automáticos en la ventana. Se debe ver el tooltip para identificar el proceso a realizar en cada caso.

Refrescar: Utilizado en la ventana de Seguimiento personal, recarga los datos del matriculado actual

Navegación: Utilizado en la ventana de Seguimiento personal, permite desplazarse entre los diversos matriculados en la escuela

Exportar / Importar: Utilizados en la impresión de asignaciones, permiten exportar los datos de las asignaciones para ser impresas por el hermano asistente de la escuela; o bien importar esos datos para imprimirlos directamente en el sistema completo.

Crear asignación: Permite crear una asignación de una parte de la escuela.

Aspecto fuera del sistema: Utilizado en el Seguimiento Personal. Permite ver y modificar la lista de aspectos de oratoria que un matriculado ha concluido fuera del sistema.

Fecha Personal. Utilizado en el Seguimiento Personal. Permite imprimir una ficha sencilla con los datos del matriculado para ser incluida en la carta de presentación en caso de traslado.

Texto Adicional: Permite imprimir un texto adicional en un cuadro en el dorso de una hoja de asignación.

Importar datos: Utilizado en la importación de datos de la escuela, permite importar todos los datos del programa de la escuela contenidos en un archivo de importación.

Control de Entrega: Abre la ventana de control de entrega de las asignaciones.

Tabla de asignaciones: Abre la tabla de asignaciones.

Cerrar: Cierra la ventana actual.


Generación

tsaSchool™. Generación

La lista de opciones de generación brindan las funcionalidades necesarias para crear un programa de la escuela completo. Contiene las opciones para generar un programa completo de la escuela, desde modificar (si es necesario) los datos del programa de la escuela, hasta crear las asignaciones, imprimirlas y llevar un control de las asignaciones que han sido entregadas.

Datos del Programa : puede registrar manualmente el título, fuente, etc; pero ahora se puede importar. Aunque también existe la opción para bajar el archivo *.imp e ir a Importar (en Utilitarios). tsaSoftware procura mantener la ultima versión del sistema con los datos de la escuela hasta diciembre del año siguiente.

Crear asignaciones .Usted elige la semana, selecciona la parte que quiere asignar y con doble clic se le abre la ventana para indicar a quien se la dará y en cuál sala. No olvide probar los botones que aparecen a la derecha de los campos de texto (los que tienen 3 puntos ...) esos le ayudan a seleccionar tanto el hermano como el aspecto de oratoria más conveniente.

Programa general del mes : brinda la opción de seleccionar una serie de asignaciones de diversas semanas, o bien de seleccionar un mes del año para generar el programa completo a imprimir. Este es el programa que se suele poner en el tablero de anuncios de la congregación.

Imprimir las asignaciones . Le permite imprimir las hojitas de asignación. No olvide ir al botón Configuración para ajustar el nombre de la impresora que utilizara y la versión de las hojas que tiene disponible. En la configuración también encontrará unos valores X y Y para ajustar la posición de los datos impresos, en caso que no impresora no los acomode correctamente. Dentro de poco existirá la opción de imprimir completa la hoja de asignación.

Control de Entrega de asignaciones . Sirve para llevar el control de las partes ya entregadas. Así nunca olvidaremos si la entregamos o no.


Datos del Programa

tsaSchool™. Datos del Programa

Al elegir la opción Datos del Programa se mostrará una ventana donde puede registrar manualmente el título, fuente, etc; pero ahora se puede importar. Aunque también existe la opción para bajar el archivo *.imp e ir a Importar (en Utilitarios).

Sin embargo, tsaSoftware procura mantener la ultima versión del sistema con los datos de la escuela hasta diciembre del año siguiente.

En la ventana de Datos del programa usted podrá ver todas las partes incluidas en el programa de la semana actual. Además podrá visualizar las partes de todas las otras semanas.


Crear Asignaciones

tsaSchool™. Crear Asignaciones

Al elegir la opción Crear Asignaciones, usted elije la semana, selecciona la parte que quiere asignar y con doble clic se le abre la ventana para indicar a quien se la dará y en cuál sala. No olvide probar los botones que aparecen a la derecha de los campos de texto (los que tienen 3 puntos ...) esos le ayudan a seleccionar tanto el hermano como el aspecto de oratoria más conveniente.

En la ventana de Datos del programa usted podrá ver todas las partes incluidas en el programa de la semana actual y crear las asignaciones. Para ello cuenta con tres métodos:

  1. Manualmente. De esta forma ud elige manualmente (de una lista que muestra a quienes pueden dar la parte en la sala correspondiente, pero sin ningún filtrado u orden establecido) el estudiante que dará la parte.
  2. Sugerido. De esta forma el sistema le mostrará la lista de aquellos que pueden dar esta parte en la sala correspondiente pero desplegando un listado de quienes llevan más tiempo sin participar en la escuela, mostrando además la última fecha y siglas de su última asignación.
  3. Automático. El sistema posee la capacidad de realizar todas las asignaciones de una semana de forma automática. Asignando tanto el encargado, la ayudante y el aspecto de oratoria. Sin embargo, se recomienda que el superintendente de la escuela del ministerio teocrático siempre revise las asignaciones creadas automáticamente para asegurarse de que el grado de dificultad y el aspecto de oratoria correspondan con las habilidades del estudiante elegido.

El sistema tiene permite el usuario que seleccione el aspecto de oratoria de forma manual (de la lista completa) o por sugerencia. En el caso de ser sugerido, el sistema le asignará el aspecto siguiente en la lista de aspectos a trabajar que tenga registrado el estudiante (en la ventana de seguimiento personal) o el siguiente en orden numérico que esté pendiente de completar.

Adicionalmente, el sistema tiene la capacidad de mostrar una serie de mensajes informativos para indicar una variedad de datos: cuando la asignación actual es del mismo tipo de parte que la última asignación del encargado, si la convinación hermana y ayudante ya ha sido utilizada anteriormente, o bien el mensaje agregado en observaciones en mantenimiento del estudiante.

El sistema se configura automáticamente para ir agregando una a una las asignaciones de cada sala. Así, al dar clic al botón Crear Asignación (o simplemente dobleclick en la parte de la lista), el sistema lleva el control de la sala pendiente de asignar y cambiará la sala según sea necesario.

En caso de querer agregar una asignación que sobrepasa la cantidad de salas, el sistema lo indicará con un mensaje, pero igualmente le permitirá el usuario crear la asignación. Esto es especialmente útil cuando un hermano no se presenta a dar la parte y se tiene que sustituir. Lo mejor es indicar que la primera asignación no se presentó y crear una nueva, de esta forma se conservan todos los datos de lo ocurrido en la escuela. Normalmente este ajuste se realiza en la ventana de Calificación de asignaciones.


Programa General

tsaSchool™. Programa General

Programa general del mes: brinda la opción de seleccionar una serie de asignaciones de diversas semanas, o bien de seleccionar un mes del año para generar el programa completo a imprimir.

Este es el programa que se suele poner en el tablero de anuncios de la congregación.

Al elegir esta opción, se muestra una ventana que permite ir seleccionando manualmente las asignaciones a ser incluidas en el programa a imprimir. También existe la posibilidad de indicarle al sistema que incluya automáticamente todas las asignaciones de un mes al programa a ser impreso.

Una vez que se han seleccionado las asignaciones a incluir, se da clic al botón de imprimir y se mostrará una ventana con el programa ya generado y listo para la impresión o exportación.


Imprimir Asignaciones

tsaSchool™. Imprimir Asignaciones

Esta opción le permite imprimir las hojitas de asignación. No olvide ir al botón Configuración para ajustar el nombre de la impresora que utilizara y la versión de las hojas que tiene disponible. En la configuración también encontrará unos valores X y Y para ajustar la posición de los datos impresos, en caso que no impresora no los acomode correctamente.

Al elegir esta opción, se muestra una ventana que permite seleccionar las asignaciones que se desean imprimir. También existe la posibilidad de indicarle al sistema que incluya automáticamente todas las asignaciones de un mes a la lista de asignaciones a imprimir.

Esta ventana tiene la opción de exportar el listado a imprimir para ser impresas por el hermano asistente del superintendente de la escuela. Así el asistente puede utilizar la herramienta hermana del sistema para imprimir las partes.

La ventana también da la posibilidad de imprimir un texto adicional al dorso de la hoja de asignación. Esto es realmente útil cuando se quiere dar estímulo a los hermanos o bien para recordarles algún punto en el que se indicó que podría aplicar el aspecto de oratoria.


Entregar Hojas de asignación

tsaSchool™. Entregar Hojas de asignación

Esta opción sirve para llevar el control de las partes ya entregadas.

Así nunca olvidaremos si la entregamos o no.

Al elegir esta opción se muestra una ventana que permite marcar cuales asignaciones ya han sido entregadas a los responsables. El propósito de esta funcionalidad es llevar un control de la entrega de las asignaciones. Aunque requiere que el superintendente de la escuela dedique un poco de tiempo a marcarlas, le asegura que todas las asignaciones fueron entregadas.

Si alguna vez le ha ocurrido que le dicen "pero hermano, usted no me entregó la parte", esta opción le será de gran utilidad.

Por otro lado, en todo el sistema se muestran las asignaciones no entregadas con un color diferente para ayudar al usuario a saber si necesita entregarla.


Calificación

tsaSchool™. Calificación

Muestra las opciones de trabajo más frecuentemente utilizadas por el superintendente de la escuela

Generar hoja para calificar . Permite crear una hoja con los datos de las parte de cada sala de una semana para calificarlas

Calificar asignaciones . Ingresa los datos de calificación de cada parte (si cumplió con el aspecto de oratoria, el tiempo, si necesita trabajar en otro aspecto, detalles importantes, etc).

Seguimiento personal . Que permite ver con lujo de detalle todo lo que ha hecho un matriculado. En esta funcionalidad se pueden agregar aspectos a trabajar (en comentarios) y el sistema lo asignará automáticamente en la siguiente asignación.


Generar Hoja para Calificar

tsaSchool™. Generar Hoja para Calificar

Esta opción permite crear una hoja con los datos de las parte de cada sala de una semana para calificarlas

Al dar click se abrirá una ventana que muestra la lista de asignaciones para la sala seleccionada.

Esta ventana permite incluir (si se han registrado en el mantenimiento de los aspectos de oratoria) los puntos a calificar como una ayuda para el superintendente de la escuela al momento de observar la parte.

La hoja a imprimir tiene una serie de campos que facilitan registrar los datos de la parte.


Calificar Asignaciones

tsaSchool™. Calificar Asignaciones

Esta opción permite ingresar al sistema los datos de la calificación de las partes de la escuela.

Aunque requiere un poco tiempo, le permite al superintendente de la escuela tener en el sistema todos los datos de las asignaciones, lo cuál es de gran ayuda para dar seguimiento al progreso de cada hermano y facilita el proceso de asignación de partes y aspectos de oratoria.

Al elegir esta opción se muestra una ventana que muestra los datos de la asignación y permite indicar:

  • Si realizó los ejercicios y se concluyó el aspecto de oratoria
  • Los detalles de la parte y el tiempo
  • Siguiente aspecto a trabajar
  • Otras opciones.


Seguimiento Personal

tsaSchool™. Seguimiento Personal

Esta opción muestra todos los datos de cada matriculado en la escuela.

La ventana muestra todos los datos relacionados con el matriculado, sus comentarios y aspectos de oratoria a trabajar, sus asignaciones presentadas, su hoja de aspectos de oratoria, partes en las que ha sido ayudante, etc.

Esta ventana también permite agregar los aspectos de oratoria ya concluidos fuera del sistema, es decir, los aspectos que ya ha concluido antes de llevar el control con este sistema.

Además permite imprimir un pequeño detalle del matriculado para enviarlo con la carta de presentación en caso de traslado.


Reportes

tsaSchool™. Reportes

Muestra las opciones más utilizadas de los reportes de la escuela

Resultados del mes . Muestra los resultados de calificación de las asignaciones del mes.

Tabla de asignaciones . Es la tabla que muchos de nosotros usábamos al principio, donde se muestra la lista de matriculados, las partes que han dado y hace cuánto tiempo no tienen asignación. Pero esta ventana es completamente configurable: por categoría de hermanos, por tipos de discurso, por sala, por fecha, etc.

Estadísticas de aspectos de oratoria . Muestra las estadística de asignación de los aspectos de oratoria.

Estadística de la Escuela. Muestra las estadísticas de asignaciones y datos generales de la escuela.


Resultados del Mes

tsaSchool™. Resultados del Mes

Al elegir esta opción se muestra una ventana que permite agregar las asignaciones del mes (manualmente o mediante la opción automática de selección de partes del mes completo) a un listado a ser impreso.

Este listado muestra los resultados de las calificaciones de cada asignación.


Tabla de Asignación

tsaSchool™. Tabla de Asignación

Al elegir esta opción se muestra una tabla de control. Es la tabla que muchos de nosotros usábamos al principio, donde se muestra la lista de matriculados, las partes que han dado y hace cuánto tiempo no tienen asignación. Pero esta ventana es completamente configurable: por categoría de hermanos, por tipos de discurso, por sala, por fecha, etc.

La ventana muestra la lista de hermanos y hermanas ordenada forma tal que siempre se muestran primero aquellos que llevan más tiempo sin participar en la escuela, según los filtros indicados y la configuración seleccionada.


Estadísticas de Aspectos

tsaSchool™. Estadísticas de Aspectos

Esta opción muestra las estadística de asignación de los aspectos de oratoria. Esta estadística le permite al superintendente de la escuela ver cuáles aspectos no han sido asignados en la escuela o ver hace cuánto tiempo no se ha asignado un aspecto de oratorio tal.


Estadísticas de la Escuela

tsaSchool™. Estadísticas de la Escuela

Esta opción muestra las estadísticas de asignaciones y datos generales de la escuela

Entre los datos estadísticos de gran utilidad se encuentran:

  • Porcentaje de cumplimiento y Porcentaje de Conclusión del AO. Que indican el porcentaje y la cantidad de partes donde se cumplió correctamente el aspecto de oratoria. Ayuda a visualizar si la escuela está cumpliendo su objetivo
  • Asignaciones estudiantiles presentadas. Para visualizar cuántas partes no se presentaron el período elegido. Esto ayuda a entender si los hermanos están siendo responsables con sus asignaciones.


Utilitarios

tsaSchool™. Utilitarios

Muestra las opciones más utilizadas de los utilitarios del sistema.

Configuración del Sistema . Permite configurar una serie de datos del sistema: título del programa, ajustes de impresión, cómo mostrar los datos, si se quieren ver los mensajes de ayuda y referencias de los estudiantes, día de la semana en que se lleva a cabo la escuela, cantidad de salas, cuántos elementos ver en la lista de matriculados sugeridos, etc.

Notas. Permite llevar una serie de anotaciones para el superintendente de la escuela del ministerio teocrático. Estas notas pueden ser como recordatorios sobre la escuela y simples recordatorios personales.

Importar datos . Esta funcionalidad permite importar los datos del programa de la escuela de un año completo. Normalmente cada octubre o noviembre se hace disponible el programa del año siguiente para que no sea necesario digitarlo manualmente.

Generar Backup. Permite generar un respaldo de todos los datos de la escuela: programa, asignaciones, detalles, etc.

Restaurar Backup . Permite restaurar todos los datos de la escuela desde un respaldo.


Configuración del Sistema

tsaSchool™. Configuración del Sistema

Esta opción le permite configurar una serie de datos del sistema: título del programa, ajustes de impresión, cómo mostrar los datos, si se quieren ver los mensajes de ayuda y referencias de los estudiantes, día de la semana en que se lleva a cabo la escuela, cantidad de salas, cuántos elementos ver en la lista de matriculados sugeridos, etc.


Notas

tsaSchool™. Notas

Esta opción muestra la ventana de mantenimiento de las notas del sistema.


Importar Datos

tsaSchool™. Importar Datos

Esta funcionalidad permite importar los datos del programa de la escuela de un año completo. Normalmente cada octubre o noviembre se hace disponible el programa del año siguiente para que no sea necesario digitarlo manualmente.

Al realizarse la importación de los datos de la escuela, el sistema mostrará la lista de semanas que serán importadas.

Es importante tener en cuenta que el sistema no reemplazará los datos actuales, es decir, si una de las semanas a ser importadas ya se encuentra registrada en el sistema, la importación la pasará por alto.


BackUp - Respaldo

tsaSchool™. BackUp - Respaldo

Estas funcionalidades permiten generar y restaurar todos los datos de la escuela: programa, asignaciones, detalles, etc.

Al dar click en la opción el sistema le preguntará por la ubicación y nombre del archivo de respaldo que se desea crear. Y al momento de restaurar los datos el sistema le advertirá que es mejor no tener ninguna ventana abierta.

Al momento de intentar restaurar los datos desde un respaldo (backup) el sistema le indicará la fecha de tal respaldo antes de proceder.

Tenga muy presente, que este es un proceso irreversible (por lo que siempre se recomienda hacer un respaldo de los datos actuales antes de la restauración)